This is important as it allows your engine to regulate its performance and change the intake of air to keep your engine running in its best condition. Just replaced the "NOT REPLACEABLE ACCORDING TO GARMIN" battery in a 765t less than a year old. 5" and has a different linearisation curve. I have the exact same car and the exact same problem, I have cleaned the throttle body, fuel injectors and MAF. I figured it might be a bad MAF so I swapped it out and the same thing occurred. when a vehicle comes in thats running poorly or has stumble when acclerating, after checking basic fuel pressures and spark KV, i check MAF sensors alot by unlugging them. when you first start the car it runs on a pre programmed set of parameters independent of sensor. Car runs okay with it not plugged in but obviously not the greatest. As soon as I take the MAF housing close to the intake and it gets some air flow through it, it'll die. First, NEVER use MAF cleaner with the engine running or even with the key in the run position. 0 Start, dies, run with MAF disconnected As strange as it sounds, its along the same lines from what a few others have complained about, but unique. It still will not continue to run even after making those changes. Anyone know if the TPS and MAF share the same circuit? Could it be possible that the TPS is shorted internally, causing a bad MAF signal when plugged in? wrong3000, try starting the car with the MAF plugged in and the TPS unplugged. Jay Safford. Currently the car is sitting with sensor unplugged and batteries disconnected. while driving the car it warms up and becomes dependant on the maf sensor to run the car properly. It doesn't run great with the MAF unplugged, but it won't run at all with it plugged in. I have the same code as you but different symptims, changing the pcv on the weekend and hope that fixes the issue. The injectors "should" have been done properly, the shop who took did the repairs are about the most reputable around here. •There could be a vacuum leak downstream of the MAF sensor. When you unplug the MAF, it starts running a safer rich tune automatically but you will get a flashing cruise light and a CEL. I didn't get to see the 2nd one and the 3rd is still attached although unplugged. They designed it to use two injectors to even-out pressure drops in the fuel rail which would give smoother running at full throttle and high RPM. 12v V6 Discussion - I never knew! Car runs fine with MAF unplugged - I intentionally left the MAF unplugged just to see/experience what would happen. If you plug it in it will die if the car is running. So i unplugged the MAF and it runs great now, now stutter at start up and full throttle is just fine but now of course i am throwing a p0102 code. With the iac unplugged it idles at 3k with the tps sensor unplugged it runs the same. When the light (or oil icon) comes on, you should immediately pull over and shut off your engine. No searches have helped. Larry stole the words right out of my mouth. The ECU will Use default values and use RPM and other things to compensate. unplugged my maf sensor - now car runs better I've been troubleshooting my 97 outback sport's intermittent rough running. L-98 Engine Start Sequence. Re: Car stall when MAF plugged in? '98 V70 Post by erikv11 » 05 Jul 2017, 04:54 If you test it the way abscate describes, and it runs better unplugged, the problem is either a bad MAF (most usually) or unmetered air getting in after the MAF (sometimes). It has a bad MAF sensor and I can't afford one right now. Have a friend with e46 318i, and her MAF started acting up. Passat MAF, problems with the MAF sensor, Mass Air Flow meter the just the cables and test the car on the road. The workshop should be able to sort it fairly easily as quattro says. stomp test shows 1213 (secondary o2 lean/rich condition, same as before). Same problem I had before. Again, with the original one, car runs fine except after clearing the code, the light comes on after the second time I start it. This exactly the same problem as I have, replaced the MAF but still runs the same. Plugged in it idles really rough and stalls if you try to rev it. In fact that is one of the test you can do to determine if the MAF is bad, if the car stumbles doesn't run right with it plugged in and maybe you have a 121 code, unplug it and if it runs OK then pretty sure bet the MAF is bad. Most gasoline cars will run horribly with the MAF unplugged but a diesel car will run OK but slow for a test drive. Re: Disconnecting MAP sensor (wiring) makes engine run great I hate to suggest parts tossing vs testing out to be certain. That's exactly what I did and the car accelerate better without the MAF connected. As soon as I take the MAF housing close to the intake and it gets some air flow through it, it'll die. Either adding or taking away fuel does not make a difference. Hell, shove a stray cat in there. To diagnose many of the problems, you will need little more than a test light, a volt meter, a vacuum gauge and maybe a can of brake clean. With MAF's unplugged, runs great all around. Not sure what else to test, or look for!. 0 range (18% less than normal). The chemicals used are hexane-based, which evaporate quickly without the use of alcohol. A common test for a failed or seriously degraded MAF is to do just this, and if the car runs better with the MAF unplugged, it's badly fouled. But, if I try and maintain about 45mph, the car is very "jerky. I’m switching over to a Hitachi MAF on my B6 A4 1. I had been running an aftermarket filter since July, and figured out that might be a cause to the problem. •The MAF (Mass Air Flow) Sensor is dirty or faulty. When you disconnect the MAF sensor, the computer switches to using manifold absolute pressure (basically like the older Ford Speed Density EFI) to run the motor. The situation is that right now i am running with the MAF disconnected completely (i disconnected it on purpose), and the car's running great (when it was connected it was awefull - stalling all the time). So I decided to unplug my iac and tps sensors to see if there was a change in idle with my car. Bad MAF will make the car run bad, and create intermittent stalling, but shouldn't make the car impossible to start and keep running. that said, it's still possible for the sleeve to be stuck, so you may well be looking at a inj pump. 0 range (18% less than normal). With maf plugged in it runs good and dies after 4 seconds, but with it unplugged it runs like any other ka in limp. What happens if you start a car without the mass air flow sensor connected How to Fix a Car that Cranks Too Long (Mass Air Flow How to know if the mass air flow sensor is. And unplugging it makes it run decent again, as before. Gonna leave car sat on drive until I can get this done as although the car runs ok with MAF unplugged, its just masking what ever is causing the issue so dont want to risk it. Car runs same with WUR unplugged? I think I understand what WUR does. Unplugging MAF normally makes the car use a kind of default reading in place of the MAF sensor reading. Either adding or taking away fuel does not make a difference. It’s dark outside and the hallway is barely lit. You believe what you want, RAVE is clear in my eyes and so is BMW info that the MAF is used to measure air temperature and volume which is used for fueling in conjunction with the MAP, car runs like a dog with the MAF unplugged. It doesn't run great with the MAF unplugged, but it won't run at all with it plugged in. If I start car it runs great, unplugged maf and same. will this harm the car should i replace maf? im looking for some educated opinions. A MAF (mass air flow) sensor is famous for causing such a problem. not bad for this light car. (Feeds relay connector "E" on all three relays as shown in the 86 ECM wiring (MAF) diagram from B1 and C16 on ECM. Depending on the make and model, your car uses either a hot-wire (the most common) or a hot. Knowing the sequence will help you troubleshoot no start conditions. The performance of the Niro’s small 1. Same maf, just does not come with the bosch stamp. not sure what this is about. Once a new one is plugged in it hardly idles and dies often. Battery voltage reads 13. The exact relays you need will depend on your harness. I have been having car woes the last two days. I have a new MAF coming in because that might be one of my 100 issues with the car right now. Then I sprayed the cleaning agent on the MAF wires and let it dry, then put it back together. It actually ran fairly normally without the MAF. I didn't get to see the 2nd one and the 3rd is still attached although unplugged. Replaced the maf sensor, and swapped mafs with 3 other people, still has the same problem with other mafs. Which technician is correct?. MAF knackered Hi all, after spending ages diagnosing idling issues on my BMW powered haynes roadster it turns out that I think the MAF is knackered. the result is i need a extra gear (6 speed. The symptoms being the car holds back at 4100rpm, like its trying to cut out almost, and it hasn't been revving freely under load. 2) I left the MAF in place, and set the second MAF on top of the motor, plugged in. However, I just had in recent years the feeling that a lot of artists / bands put out an unplugged album to bring their falling asleep career back on track. Could also be the cam position sensor - the harness connector is easy to knock loose when working in the engine bay. Your test doesn't prove much of anything. No "jerkiness" or idling problem. Edited April 8, 2013 by plumajp. Nissan Sentra Failed Mass Air Flow Sensor May Cause Driveability Issues - 178 reports. Same problem, sputters, spits, coughs. Air filter has nothing to do with it. As soon as you unplug the MAF its fine. Much more common, however, are failure modes in which the MAF sensor has become unreliable, underreporting or overreporting the true airflow into the engine. will this harm the car should i replace maf? im looking for some educated opinions. We changed to a brand new MAF and it still runs terrible with MAF plugged in, runs like a champ with MAF unplugged. When a MAF fails it sends feedback information to the PCM that the engine is running at 1800 RPM so the computer will lean down the mixture. If I plug the MAF in with the car. If i put the new MAF, car runs great, but dies on idle. the car runs smoother through the rev range, and fuel economy is the same or better. 13 Answers I have a 06 pontiac vibe with a VVTi 16 valve motor. 1 don't work over USB (you can get sound but no info is displayed and you can't control from the stereo unit). I'm surprised the car even ran at all. Took the car back few weeks ago and they rechecked the timing and cylinder pressure (right term?) and they said everything was up to the speck. plugged the MAF back in and the CEL stayed on, even after restarting the car. This can cause major damage to the sensor. Stalling is caused by a loss of air, fuel, or electricity while the engine is running. It’s that easy! Now You Know How To Clean A Mass Air Flow Sensor! Knowing how to clean a mass air flow sensor can save you money and keep your engine running at its peak. Once a new one is plugged in it hardly idles and dies often. Unplugged the car starts up and stays running. To diagnose many of the problems, you will need little more than a test light, a volt meter, a vacuum gauge and maybe a can of brake clean. MAF car runs the same when unplugged MAFland MAF car runs the same when unplugged - GN and T-Type Performance Enthusiasts (GNTTYPE) Forums This is a general site search and does not include list archives. And I've unplugged each separately and I get the same result. I would literally want the exact same size and type cone filter but in. It turns over, idles ROUGH and then dies. I unplugged the sensor tonight and after a couple minutes it idled smoothly, not rich, and no miss. All you boost junkies been ordering kits like crazy. The most common symptom, when the MAF sensor gets dirty (contaminated) is that the engine bogs down when you accelerate the car (or mini-van) but it will idle fine. The car will start and seems to run fine for a few seconds. My car listed above GLT model, start and runs then stops. 0 range (18% less than normal). The iPhones running iOS 8. * STOCK 1990 2. There are various designs of MAF sensors, but the most common by far is the hot wire MAF sensor. I didn't think a faulty turbo would cause a MAF fault, unless this is on top of the MAF fault, haven't noticed any differences in the running of the car unless its been like that since we got it will have to wait and see, with any luck it will drive like a new car when I pick it up tomorrow!. But MAF's also give different symptoms when they pack up. The rate of discharge depends on the type of battery. It ran the same and in about 5min of driving the CEL was back on. The MAF is the sensor that tells the ECM (engine computer) how much air is entering the engine at any give time. 8T because I have one laying around and my car is now running a hybrid RS6/K04 turbo so the stock sensor wont fit on my TIP and will probably be maxed out on this turbo. As a rule of thumb, the older the vehicle the more likely this problem is. -check So, the last thingi could think of was replacing the main cat o2 sensor?. EDIT: Furthermore, if the engine refuses to run with the MAF disconnected, you should probably start looking for other potential problems. -Cleaned the MAF's with MAF cleaner, still runs bad. Not sure what else to test, or look for!. on cars with both map and maf the pcm will also use the map sensor to check the egr and other rationality checks. took a little while to figure it out but the maf was bad and caused the plugs to foul. when i unplug the MAF the p0172 code goes away and the code for the MAF appears. Car would barely run with the MAF plugged in. 5i at 08:23pm on May 31, 2010. I have the same code as you but different symptims, changing the pcv on the weekend and hope that fixes the issue. If i unplug it, it runs very rough, nothing like before the issue. I would literally want the exact same size and type cone filter but in. Try exchanging the MAP sensor from the other "good running" car. Driving with MAF unplugged General E46 Forum. took a little while to figure it out but the maf was bad and caused the plugs to foul. I let it sit for 6-8 hours ant then reset the ecu, and the car ran fine for the past 2 weeks. If it runs fine with it unplugged its most likely your problem. When my MAF packed up the car was dead up to about 2500 rpm then suddenly the turbo kicked in for a short while. Vw Tdi Overboost Problem. Today i tried running the car with the camshaft postioner unplugged, this being the no. if its still operating withing its Hertz and grams per second perameters it will not set a code. Stop working in my Car via USB. 2010 fusion won’t start or run with maf plugged in Custom Search Sign in to follow this. EatShark, the MAF is on the side and has four pin connector and the sensor is a box on a circular metal housing. The car was tuned by JZW before I purchased it. when it was plugged in the car ran soo rich that it actually would kill the motor. 2, only done 19000mls and has code p0100,so decided to replace the maf with another new bosch one. I noticed for the 1st time ever since owning the car that both cooling fans kicked on within a minute of the engine running. She did say that the car felt more responsive with better fuel consumption after I installed the new MAF. I have a 1993 240sx. Of course, there are differing thoughts. The MAF, Mass Air Flow meter is the sensor who indicates to the ECU (car computer) the air mass who flow inside the engine. The car has better mpg and runs better (I know the egr shuts off when maf is not present with less turbolag etc) when the Maf is unplugged. MASS Air Flow MAF Sensor plug connector pigtail wire Fits Nissan Sentra QG18DE | eBay Mass Air flow Sensor (MAF): how it works, symptoms, problems, testing Free shipping 10 sets 1J0973775A Mass Air Flow Sensor 5 Pin Connector Plug For VW Volks with wire or without wire. Much more common, however, are failure modes in which the MAF sensor has become unreliable, underreporting or overreporting the true airflow into the engine. This trick comes in handy when you are a poor high school student and can’t afford a new MAF until next pay-day. Thinking it was just a MAF I brought a know good MAF from a 93 TSI talon and swapped it but it didn't change anything. I have fitted an LS2 to my VZ SS, the LS2 90mm ETC throttle body has no provision for a pvc hose. But it halfway runs without the MAF plugged in. Car is running, but rough. The ratio of the larger hollow. -Cleaned the MAF's with MAF cleaner, still runs bad. They both used to work fine before the updates. I have a new MAF coming in because that might be one of my 100 issues with the car right now. had some rough idle issues at one point (not with a vivaro mind) and looked in to MAF sensor issues. As a rule of thumb, the older the vehicle the more likely this problem is. It stalls and I can smell unburnt fuel in the exhaust. To me, information about the MAF is very confusing, My car runs well with the MAF plugged and unplugged, when the MAF is plugged my idle and redline readings are within spec but I run lean. And others are wondering the same thing. took a little while to figure it out but the maf was bad and caused the plugs to foul. The car runs better without it plugged in. I haven't cold-started the car with the MAF unplugged, but I bet this will get rid of my sluggish cold throttle response problem too. If it is there try to clean it with MAF sensor cleaner (dont use other cleaners). I would literally want the exact same size and type cone filter but in. ) Parameter: B1509 Set to any value below any expected temp. It can be helpful to take a look at them with the vehicle's engine running so that you can listen for whistling or hissing sounds indicating a leak. I then unplug the MAP and it runs okay again (until finally it dies after a few minutes) Here’s a list of what I’ve checked and replaced: Checked for vacuum leaks-none found Removed Cat. Air filter has nothing to do with it. It must have been pulling it's air fRom there and causing the maf not to get any air flow. Bad MAF will make the car run bad, and create intermittent stalling, but shouldn't make the car impossible to start and keep running. The MAF sensor appears to be sending values back to the ECU, but the car stays in limp mode even after a reset. Was able to plug the car into a computer to see what the ecu was doing and is cutting fuel by 25%. I need some help on this as its my DD, and I am stranded. 2010 fusion won’t start or run with maf plugged in. If it runs fine then the MAF is either dirty or faulty. (However, before you run out for a larger Ford MAF meter, Fast Track Performance points out that the first limiting factors are the puny Ford 19 lb/hr injectors, which can only support about 320 hp. if the car is 3. I unplugged it while the car was running and the car simply died. I think as the problem goes away when the MAF is unplugged it must be a fuelling issue? If I had a vacuum leak it would be present with MAF plugged or unplugged?. ) I have a theory that there is a bug in the SCT software for the 96 Cobra LLX3 and 97 Cobra LLX4 PCMs. I unplugged the new MAF and then it revved super high. and its misleading to say that the map sensor measures vacuum while its not entirely false if you hook up a vacuum gauge it wont read the same as the map sensor. did the same thing when i unhooked it. The EFI system isn’t really that complex on a fox body Mustang, it has a few sensors, solenoids, relays and a computer handling all this input to strive for the best fuel ratio for most performance and mileage in all possible conditions. There was a fried body ground from the engine to the chassis, and a bad ground at the MAF. If I plug the MAF in with the car. Running on a stock Mitsubishi MAF sensor is a great idea for dialing in SD because it tends to produce a very accurate signal. I take out the MAF and used CRC Mass Air Flow cleaner and cleaned out the air filter box. What ECU have you got? how did you wire up the ecu to think it's in gear? I had the exact same issue turned out to be the neutral start switch wire needed grounding. Frustrating Mistake. Unplugged Chapter Twenty. I think it was a goosed cam position sensor at fault. I explain that Ford did that because its the only engine they come with. I'm about to go pull the whole harness out and look at it. If you want to ruin your nuvi battery leave it plugged in all the time. I got the nissan Datascan to try and diagnose the problem, also usefull for monitoring/logging. Just replaced the "NOT REPLACEABLE ACCORDING TO GARMIN" battery in a 765t less than a year old. changed ait and tps and it fixed it, never narrowed it down to which one it was tho. If the car runs better plugged in, then your problem is most likely not the maf. Bad MAF will make the car run bad, and create intermittent stalling, but shouldn't make the car impossible to start and keep running. The MAF measures a few different things while differential pressure only measures pressure drop which makes MAF readings less repeatable which is important for "scientific" modification. In fact that is one of the test you can do to determine if the MAF is bad, if the car stumbles doesn't run right with it plugged in and maybe you have a 121 code, unplug it and if it runs OK then pretty sure bet the MAF is bad. Be advised there are two types of MAF for this era Subarus 2005-2008 and the part numbers are confusing people, even Amazon. Ordered a used MAF from the junkyard and they gave me one from a '91 LeSabre 3800, apparently their info says it should be compatible, installed it and it runs exactly the same as the old one. With the iac unplugged it idles at 3k with the tps sensor unplugged it runs the same. I have fitted an LS2 to my VZ SS, the LS2 90mm ETC throttle body has no provision for a pvc hose. The stock MAF meter and computer are calibrated to run with 14lb. Running Car with MAF unplugged TDI 101. My issues I am having to include rear 02 sensor issues, is weird boosting, shifting, very weak performance and BAM strong, very poor gas milage and smelly gas. bad maf, old rule of thumb if the car runs better with it unplugged or if you can tap on it and it stumbles or dies it is usually bad, id look into the maf sensor, could be a possibility Epetrelli91 is offline. If you unplug the MAF sensor your car still runs. I think as the problem goes away when the MAF is unplugged it must be a fuelling issue? If I had a vacuum leak it would be present with MAF plugged or unplugged?. The car went into Limp mode. Car seems to run okay when started from cold. I think it was a goosed cam position sensor at fault. And others are wondering the same thing. In some cases, a dirty MAF sensor doesn't really cause a lot of havoc with the way your engine runs. If the car run in the same way, or even better, you can be sure, the MAF sensor is gone. I've driven about 75 miles with the maf wire inbetween the air filter and intake not connected. Leave the MAF plugged in. Car RUNS at 120 -149 Degrees F, and has HORRIBLE gas mileage and a weak cab heater, or overheats! or the G16 stat will surge, bad used in any DOHC engine. Does anyone know where i can find a replacement RED cone filter for the Injen CAI. MAF sensor was cracked and throwing a code, so I replaced it. Driveability of the car was IDENTICAL. Did the ecu fault code check and didn't show any faults, apparently will only come up as a fault if the sensor is knackered won't come up if sensor is failing which mine was. Most gasoline cars will run horribly with the MAF unplugged but a diesel car will run OK but slow for a test drive. It's not going to affect how the car idles. installed last night, DID NOT unplug MAF, worked fine this morning, no CEL Tonight, i decide to use the MAF cleaner (it was late last night, figured id clean it today)- unplugged like the directions said, sprayed it down with the cleaner, let sit for an hour or more- it seemed to dry really fast. Hell, shove a stray cat in there. Note: The use of "oiled" air filters can cause the MAF to become dirty if the filter is over-oiled. It runs with no sensor plugged in because the ECU notices it's absence and runs the car on a generic stored reading. Took the car back few weeks ago and they rechecked the timing and cylinder pressure (right term?) and they said everything was up to the speck. Locate the car's vacuum lines, and look them over, checking for unplugged connections, as well as signs of wear and cracking. Q: Car runs with the mass airflow sensor unplugged. But, if I try and maintain about 45mph, the car is very "jerky. I didn't get to see the 2nd one and the 3rd is still attached although unplugged. The symptoms being the car holds back at 4100rpm, like its trying to cut out almost, and it hasn't been revving freely under load. I cleaned it after that it gives me a p102 code says MAF sensor problem. Your ECU will use preset maps (open loop) to run. Still getting the p0345, p0349,m p0020 (vct unplugged) to keep from just blowing the motor intentionally or parking the car in front of a speeding locomotive, etc. You need to drive it a lil bit to see the effect. Open your MAF-1 working tune (the one you flashed to do this log) and go to Engine > Airflow > General Airflow > MAF Calibration, Airflow vs. When the ECU sees the the MAF disconnected, it uses reading from other sensors (tps+02) to get a false value for the MAF to keep the car running well. 22 Mar 2010 (Click here for the 4 wire VW Bosch MAF Sensor Test) symptoms when the Air Flow Meter (MAF Sensor) goes BAD but, the Of course, you have to keep in mind that a dirty VW MAF sensor will not cause a lot of havoc. sr20det runs better with o2 unplugged? So my car has been running pretty ****ty last month or 2(s13 sr20det black-top). Everyonce in a while after starting the car for the first minute or so the car would run bad. Injector amps are all about the same, I'm measuring about 8 amps each which sounds a bit low but my amp clamp currently has a temporary repair where I caught the cable in a door, so not taking the measurements as 100%. Well Ive been on and off trying to fix my car, yesterday my dad disconnected the maf and the car heald a steady idle. In a DSM, this is the fuse that controls the footlights that go on when you open your car door. Note: The use of “oiled” air filters can cause the MAF to become dirty if the filter is over-oiled. Boom! Car is running and back in business, low idle gone, car runs beautifully again. Not really missing, just kills if the MAF is plugged in and definitely doesn't do low speeds well without stumbling and killing. I've tried cleaning and replaced maf with another one and got same results, both times disconnecting the battery to let computer reset. After you have checked for vacuum leaks and lose wires etc. 2, only done 19000mls and has code p0100,so decided to replace the maf with another new bosch one. Just completed a single turbo conversion. Will take a look and see it I can secure it. stomp test shows 1213 (secondary o2 lean/rich condition, same as before). The fueling calculation is so central to the engine's operation, that the car just can't run optimally. I guess because most of the idle problems disappeared with the MAF replacement. What happens if you start a car without the mass air flow sensor connected How to Fix a Car that Cranks Too Long (Mass Air Flow How to know if the mass air flow sensor is. When the MAF is unplugged, the PCM goes to a default setup and does it's best to properly meter fuel using other senors, so if it is bad and it is causing a stalling issue, it should run with it unplugged, but there may be a difference in gas mileage. When i unplugged the MAF the car pulled way better and more like it supposed to be. Naturally, I thought the maf was bad, but when I swapped the maf (with a known good one) I have the same problem. Most gasoline cars will run horribly with the MAF unplugged but a diesel car will run OK but slow for a test drive. It just doesn't seem likely that a fouled MAF sensor would totally kill an engine, but I have no idea, as I've never dealt with the issue on a car before. Perform the same checks while lightly tapping on the sensor, or heating the sensor with a blow dryer. My car listed above GLT model, start and runs then stops. Still runs good, but the CEL is on. If there's any air leak at or after the MAF, that is a problem. EDIT: Furthermore, if the engine refuses to run with the MAF disconnected, you should probably start looking for other potential problems. Note: The use of “oiled” air filters can cause the MAF to become dirty if the filter is over-oiled. (I forget what that part is, I think it is a three pin connector). The input bolts to the airbox. Frequency and highlight the entire table. 8 ,sputtering and shaking on acceleration , Unplugged Maf Sensor , Car runs Great now , Is this sensor bad? Can I drive it with the sensor unplugged or dangerous to engine? Cas has 250000 Miles on it. So i don't know what to do, put in the GM MAF, or just run 20 psi till I can get my injectors and dsmlink? My car runs excellent with the 2G mas. i had the same problem with my buddy 91. Well Ive been on and off trying to fix my car, yesterday my dad disconnected the maf and the car heald a steady idle. I have the bluetooth connect and don't see that option in the menu. Note: The use of “oiled” air filters can cause the MAF to become dirty if the filter is over-oiled. I've been experiencing a hesitant, rough idle for several thousand miles as well as a CEL. New battery No more charging probs since. The performance of the Niro’s small 1. as it runs fine when the MAF is unplugged. My 2002 will run, but poorly, with the MAF electrically unplugged - BUT the IAC is in the MAF, so that factors into the problem. Wow, this is what I was trying to say, just wayyy more eloquently done. Pattaya to hold 80 Years of Batman Night Run September 21 PHOTOS: PR PATTAYA Pattaya – The 80 years of Batman Pattaya Night Run will be held next month at Terminal 21 Pattaya and Pattaya Beach. Circuit Descriptions Of The GM MAF Sensor Connector. I have a new MAF coming in because that might be one of my 100 issues with the car right now. One MAF is about 1 inch wide across the top, the other is wider and larger. -Don't detect any vacuum or exhaust leaks. When the MAF is unplugged, the PCM goes to a default setup and does it's best to properly meter fuel using other senors, so if it is bad and it is causing a stalling issue, it should run with it unplugged, but there may be a difference in gas mileage. I think I may also have a vaccum leak. Since I got my car I had a tps problem. Unplug the MAF and see if the car runs better. no CEL, but the car still ran like crap and wouldn't acclerate. not bad for this light car. Car runs pretty damn good without the MAF plugged in. If you try to plug it in while it's running the car will die. Car ran fine with the maf disconnected. It would crank start and then die. Driveability of the car was IDENTICAL. 8mm center area, 56. One of our readers posed the question about running a laptop without the battery. Jan 1, 2012 #1. i thought the MAF was bad prior to replacing it since when i unplugged it the car ran perfect. I hope this makes sense, I have had a few. Hell, shove a stray cat in there. Unplugged MAF & car ran better & smooth (didn't die this time).